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Unit Details e eu =

Work Area 9 ICT SKILLS

3.15 Use spreadsheets to produce sheets at an intermediate and
advanced level: Part A n 2

LO3.53 Demonstrate skills in using Spreadsheet software at an intermediate
and advanced level to produce complex worksheets that conform to agreed
specifications. Take some responsibility for the evaluation of the result. '
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Freeze rows function e eu =

* You may want to see certain rows or columns all the time
in your worksheet, especially header cells.
By freezing rows or columns in place, you'll be able to
scroll through your content while continuing to view the
frozen cells.

To freeze rows:

1. Select the row below the row(s) you want to freeze
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Freeze rows function e eu =

2. Click the View tab on the Ribbon.
3. Select the Freeze Panes command, then choose Freeze Panes from
the drop-down menu.

2 Bar Q _'é "C)\| I_E E E = split

15 foom 100% Zoom to Mew Arrange| Freeze | Hide
Selection | Window Al |Pames =
Zoam Unfreeze Panes
TI Unlzck all rows and columns to scroll
o through the entire worksheet.
3 E F B H ___ Freeze Top Row

Keop the top row visible while scrolling
through the rest of the workcheat.

eze First Column

Fre
| Keep the first column visible while screlling
= -
through the rest of the workshest.
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4. The rows will be frozen in place, as indicated by the gray line (below
the first row). You can scroll down the worksheet while continuing to view
the frozen rows at the top.

H ®-
File Home Insert Page Layout Formulas Data
M — 0 0 s — | rl|—
Formula Bar Q -3 Q
3 SIS 5 m - ]
Mormal Page El'eak Fage Il'.u:f.mm Erdiines Headings Foom 100% ?nnm_m .New &
Preview Layout Views Selection | Window
Warkbook Views She Foom
AZl S Jx
A B C D [ E [ F G

Employee Paosition

Pater, lohn Managers
_Mary, James Marketeers
_Elizabeth, Kathy Office Administrators
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Select the column to the right of the column(s) you wh
to freeze. In our example, we want to freeze column A, so we'll
select column B.

2. Click the View tab on the Ribbon.

3.

Select the Freeze Panes command, then choose Freeze

Panes from the drop-down menu.

.

/




Freeze columns function

4. The column will be frozen in place, as indicated by
the gray line between the two columns. You can scroll
across the worksheet while continuing to view the frozen
column on the left.

H 9
File Home Insert Page Layout Formulas Data
| ! £l [¥] Formula Bar q é C
Normal Page Q:eak Page Cu§tom [ Gridlines [ Headings Zoom 100% Zoon
| Preview layout Views Selec
Workbook Views Show Zoom
A21 y S

A 8 C D E F
1 Employee Position
2 Peter, John Managers
3 Mary,James  Marketeers
4 Elizabeth, Kathy Office Administrators
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ﬁ?: To unfreeze rows or columns, click the Freeze
Panes command, then select Unfreeze Panes from
the drop-down menu. -

} L',_ = split

™ Hide

ge Freeze
Panes ~ Wi

Unfreeze Panes

Em | Unlock all rows and columns to scroll
through the entire worksheet.
Freeze Top Row 1
E=E Keep the top row visible while scrolling

through the rest of the worksheet.

__ Freeze First Column
—1 Keep the first column visible while scrolling
through the rest of the worksheet.




Certiication tar

IF function |

Ll

’ v : . e . a

ﬁThe IF function allows you to make logical
comparisons between a value and what you
expect.

* |nits simplest form, the IF function says:
* |F(Something is True, then do something, otherwise
do something else)

e So, an IF statement can have two results. The
first result is if your comparison is True, the
second if your comparison is False.

Yy
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=IF(C2="Yes"”,1,2)
In the example, cell D2 says: IF(C2 = Yes, then return a 1,
otherwise return a 2)

=|F(C2=1,"Yes”,”No”)
In this example, the formula in cell D2 says: IF(C2 = 1,
then return Yes, otherwise return No)
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/Conditional formatting applies one or more rules to any
cells you want.

e Accessitinthe Home tab
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/To create a conditional formatt@

rule: :
1 FEICEIGIBE
* SeIeCt the CeIIS you Wa nt to add EcundHiml Fermat as :]I |r|=!.'f|. Illr_'h.'tl:luml:'. I Efn
. Forrmattimg < | Table - Styles - ” - # - i
formatting to. o 2 -
i SeIeCt nghllght CE”S ] | Tﬂ Top/Bottom Rules * |TJ-"-'55Tha“"- P
Rules or Top/Bottom Rules. We'll Flowsn 0 B soween.
choose Highlight Cells Rules for this (B corsons [ e
example. A menu will appear with "" e ——
several rules. e ==

Manage Bules Duplicate Values...

* Select the desired rule (Greater Mo .
kThan, for example). /




/From the dialog box, enter a vaIue}

the space provided

In this example, we want to format
cells that are greater than 50, so
we'll enter 50 as our value.

Select a formatting style from the
drop-down menu.

Conditional formatting offers many
more options and functions. Go

kahead and explore!

P
Greater Than

L9 e

that are GREATER THAN:

F8| with LiohtRed Fill with DarkRed Text v

ok || cancel |

/

Clipboard ™= Font Alignmer
B L E F
1 ALCOH  FOOD TRPORT X
2 3 8.99 167.05 0 80.51 692
3 2 17.75 T0.78 0 4072 272
4 2 297 177.2 0 29.31 1130
L 2 135 7511 2 38.11 535
& 2 47 41 147 .89 0 10827 767
7 2 4973 116.94 0 503.75 682
B 2 58.07 74.85 2 76.15 1008
9 2 34 56 101.24 0 2722 1132
10 2 291 68 49 2 b4 .76 891
11 2 22 190.3 0 AT AT 1264
12 2 17.95 4529 0 78.86 T38
13 2 3179 7518 1 5723 431
14 3 479 128 A3 1 A7 7T 1271




Select the cells that have conditional
formatting.

In the Home tab, click the Conditional
Formatting command. A drop-down
menu will appear.

Select Clear Rules.

A menu will appear. You can choose to
clear rules from the Selected
Cells, Entire Sheet, This Table, or This
PivotTable.

N
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Creating a pivot table

Click a cell in the source data or table range.

Go to Insert > Tables > PivotTable.

Excel will display the Create PivotTable dialog with your range or table name selected.

In the Choose where you want the PivotTable report to be placed section, select New
Worksheet, or Existing Worksheet. For Existing Worksheet, you'll need to select both
the worksheet and the cell where you want the PivotTable placed.

If you want to include multiple tables or data sources in your PivotTable, click the Add
this data to the Data Model check box.

Click OK, and Excel will create a blank PivotTable, and display the PivotTable Fields list.




/In the Field Name area at the h
select the check box for any field you

want to add to your PivotTable.

By default, non-numeric fields are
added to the Row area, date and
time fields are added to
the Column area, and numeric fields
are added to the Values area.

* You can also manually drag-and-drop
any available item into any of the
PivotTable fields, or if you no longer
want an item in your PivotTable,

Cariication {or
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simply drag it out of the Fields list or
uncheck it.

PivotTable Fields
Choose fields to add to report: 4 -
Search ya.
MONTH -
CATEGORY
AMOUNT hl
Drag fields between areas below:
T Filters Il Columns
MOMNTH ~
D
= Rows * Values
CATEGORY - Sum of AMOUNT -
- 5 e
Defer Layout Update
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/Summarize Values By \

* By default, PivotTable fields that
are placed in the Values area will Z Values
be displayed as a SUM. Sum of AMOUNT  ~

* If Excel interprets your data as
text, it will be displayed as
a COUNT.

 This is why it's so important to
make sure you don't mix data
types for value fields.

* You can change the default
calculation by first clicking on the
arrow to the right of the field

name, then select the Value Field
Settings option.

Y Move to Report Filter
= Moveto Row Labels

ll Moveto Column Labels

X Remove Field

i@ ValueFField Settings...




Working with a pivot table CR-1

Next, change the calculation in
the Summarize Values
By section. Note that when you
change the calculation method,
Excel will automatically append
it in the Custom Name section,
like "Sum of FieldName", but
you can change it.

If you click the Number
Format button, you can change
the number format for the
entire field.

Value Field Settings

Source Name: AMOUNT

Custom Mame: | 5um of AMOUNT

Summarize Values By  Show Values As

Summarize value field by

Choose the type of calculation that you want to use to summarize
data from the selected field

-
Count

Average

Max

Pin

Product i

HNumber Format Cancel

A
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1. SUM

* Formula: =SUM(5, 5) or =SUM(A1,
B1) or =SUM(A1:B5)

e The SUM formula allows you to add
2 or more numbers together. You can
use cell references as well in this
formula.
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/ 2. COUNT i

Formula: =COUNT(A1:A10)
* The count formula counts the number of
cells in a range that have numbers in them.
* This formula only works with numbers. It
only counts the cells where there are
numbers.
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3 COUNTA

Formula: =COUNTA(A1:A10)
* Counts the number of non-empty cells in a
range. It will count cells that have numbers
and/or any other characters in them.
e The COUNTA Formula works with all data
types.
* |t counts the number of non-empty cells no
matter the data type.
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Formula: =LEN(A1) (S ¥R | i
* The LEN formula counts the number of [ Ji" 1§ ’ gy |\ =
f characters in a cell, incl. spaces A [ | .
. .
R 5. TRIM _ 4_
| e Formula: =TRIM(A1) \

|  Deletes spaces in a cell, except for single ‘
’ spaces between words.



Essential advanced formulas
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6. RIGHT, LEFT, MID

Formulas: = RIGHT(text, number of characters),
=LEFT(text, number of characters), =MID(text, start
number, number of characters).

These formulas return the specified number of
characters from a text string.

RIGHT gives you the number of characters from the right
of the text string

LEFT gives you the number of characters from the left

MID gives you the specified number of characters from /8

the middle of the word.
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/. SUMIF, COUNTIF, AVERAGEIF bt herer antifin

 Formulas: =SUMIF(range, criteria, sum_range),
=COUNTIF(range, criteria), =AVERAGEIF(range,
criteria, average_range)

* These formulas all do their respective functions
(SUM, COUNT, AVERAGE) IF the criteria are met.
There are also the formulas: SUMIFS, COUNTIFS,
AVERAGEIFS where they will do their respective

functions based on multiple criteria you give the
formula.
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‘ 8. CONCATENATE

R Combining data in 2 (or more) different cells
into one cell.

 This can be done with the Concatenate excel
formula or it can be done by simply putting the
& symbol in between the two cells.

* If | have “e-EUPA” in cell A1 and “project” in cell

B1 | could put this formula: =A1&” “&B1 and it

would give me “e-EUPA project”.

44 - ‘.‘_“‘:—T‘i.,,

dS
b
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More Excel Formulas
 Time formulas (NOW, TODAY, MONTH,

YEAR, DAY, etc.)
Other formulas like AND and OR
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ey B - M O E E

1 |A ALCOH FCOOD K TRPORT X
2 3 8.95 157.05 li] BO.51 592
3 2 17. 75 T0.F8 1] 40,72 272
4 2 297 1772 o 29 31 1130
e Toinsert a chart: | o oER o oEn o=
O Inser a C ar * T 2 4973 116.54 li] L503.75 EB2
8 2 53 .07 T4 85 2 76 15 1008

5 1. §
* Select the cells you want to chart, B 2 A% nm 9 Zz us
1 Z 22 190 3 1] 57 AT 1264
. | d . t h | t . t I d 12 2 17.95 4529 i 78.BE 738
13 2 31.79 7518 1 E7.23 431
including the column titles and row Bl 2w w1 wa e
15 2 26.97 85 63 3 701 709
M 16 1 18 .69 8114 1] 1091 451
|abe|S. These Ce”S W|” be the source 17 2 w7 1173 3 1073 975
18 1 728 &3 56 1] 18 98 309
d f h h t 19 2 463 110.51 2 79.34 15
20 1 513 40.64 li] 31.95 206
ata Or t e C ar ° 21 2 13 .85 241 23 | 167 .12 445
22 3 2687 158.49 1 109.89 797
23 2 36 493 25 2 713 495
* |In our example, we have selected al 3 37 w1 omp on
25 2 3.83 115.03 3 226 859
26 2 a3 .13 244 3 1] 165509 1303
L ]

cells A1:F24. Bl s as o am
29 1 4 63 .44 1] Z01.35 480
30 2 21.29 53 29 li] 36.51 &0
| 1 0.5 29 14 1] 11.95 144
32 1 4.38 17257 4 244 8% E16
33 b 12 65 100 62 3 b4 93 s06
4 2 2055 53.T78 o 21.74 192
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From the Insert tab, click
desired Chart command. In
example, we'll select Column.
Choose

preferred chart type from
drop-down menu

the \

our

the
the

/

1?

Recommended
Charts

— L
dm B (HA
dn 89 08 49
% = =

il More Column Charts...
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ﬁThe selected chart will Q

inserted in the worksheet. e

722 1132
1 i

* Excel allows you to add chart S To st

78.86 100% o

elements 5723 | 90%

1777 | sox +
70.1

* To add a chart element, click 03| 7% |

.73 60% T

the Add Chart Element command 1098, son

195 | 0% T

on the Design tab, then Laz| oy

20%
713

choose from the drop-down %4z ™|

DD -1
35.09 1 3 5 7 @ 11 13 15 17 13 21 23
\menu. /

uTRPORT
mEK
EFOOD [

mALCOH




KFrom the Review tab, click Spelling\

 The Spelling dialog box will appear.
For each spelling error in your
worksheet, Spell Check will try to
offer suggestions for the correct
spelling

« A dialog box will appear after

reviewing all spelling errors. Click
\\OK to close Spell Check.

E | E i G | H 4

TRT Spelling: English (United States)

| Not in Dictionary:
nause [ fgroreonce|
Suggestions:
.
hawse
- | ChangeAl
Hausa TS
- | AutoCorrect
: Dictionary language: | English (United States) E|
[| o]




Create a spreadsheet
E-EUPA LO _3.53 M 001
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Question 1

ici : T o.
Revision Questions ‘e eu ==

for

Question 2
Which functions of excel are * How can we check spelling and
necessary

processing
documents?

creating  or grammar of a spreadsheet?
non routine

Question 3
e How can we add a chart?




- /" o
Module Key points ‘e eu ==

Excel spreadsheets organize
information

Formulas and Functions
Freeze panes
If functions
Conditional formatting

VLOOKUP
Pivot tables |

T e
Other formulas -

Charts
Spelling and grammar
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